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RPlusD is now complete. The completed manual is posted in PDF format. In cases where the
existing PDF docs have incomplete explanations, detailed explanations can be found in the
respective help files. The program has an extensive help file for the various special function
windows that describes each of the respective functions in detail when the help button is clicked.
In many cases documentation written for programs is not read. RPlusD has a series of videos
that shows the basic functions of an earlier beta version of the program and are sufficient to allow
users to learn how to use the graphical user interface (GUI).
This document has pictures of the various windows and a brief description of each function.
RPlusD runs in all current MS operating systems (including Vista) and requires a full duplex (play
and record at the same time) sound card. The information regarding sound cards is in FAQ's and
in the GettingStarted PDF document. Almost any sound card will work as well if the necessary
functions are built into the sound card. The software will be as accurate with a low cost sound
card as it will be with the best sound cards available. One does not require a high quality sound
card to take accurate measurements because RPlusD uses the left channel to measure the
response of only the sound card using a direct left out to left in connection. The response errors
in the sound card are known and are removed from any measurements. This provides very close
to 100 % accuracy in measurements.
The unique capability of RplusD is that of EQ emulation. This is allows the user to simulate EQing
a system with 32 measurement microphones taking data in real time. It is much faster than doing
it this way because the measurements are first taken then EQ emulation takes place in software
and can be computed much more quickly than measurements can be repeated in real time. This
feature makes RplusD the ideal tool for people who wish to use digital equalizers. It is the opinion
of the author that DSP Eqing is a very effective way of improving sound quality of home theater
systems in playing back dialogue. Popular Behringer EQ's are precisely emulated inside the
software. The software provides a utility for setting any EQ to the EQ solution obtained using
RplusD. There is no better way to EQ systems.

Feature List & Descriptions
Data Gathering
The Audio Data Gathering window is available from File->New->Normal Room/Speaker
Measurement. The 'MLS (Xover sim)' button does not appear unless the enhanced package is
bought at an additional cost above that of the basic program. This add on package is
recommended for advanced users that want to do curve fitting, DSP crossover emulation or
wireless measurements. Most new users that are uninitiated to audio measurements will benefit
more from buying the consultation option that gets the program designer working with them rather
than buying the add on package that provides the more sophisticated functionality.
RPlusD provides sweep, MLS and a 'hybrid' measurement that combines an MLS signal at mid &
high frequencies with a sweep for low frequencies. The hybrid signal is best for full range speaker
measurements. The sweep is best for RT/60 measurements. The MLS signal is mainly used only
for DSP crossover emulation measurements. RPlusD also has the option of auto ranging your
mic speaker distance inside the software or allowing the user to type in a value. Subwoofer

measurements require the value to be typed in but full range measurements can normally make
use of the Auto function quite well.

Audio Data Gathering Window
For users that wish to measure the time response in real time while placing absorbers a separate
module is provided. This is available from File->New->ImpulseRTA. This feature provided pseudo
real time impulse or ETC measurements to be taken to optimize absorber placement. This display
can update as quickly as once every fraction of a second depending on the period settings.

Impulse RTA

Printing & Graphic Export
RPlusD has a JPEG export utility that is available for all users. This is a convenient feature for
posting results on discussion groups. The *.jpg file exported is the same size as the graphic. The
printing capability is provided for Add On Package licensees and commercial users. This feature
uses a 3rd party component to generate exportable graphic from all mathematical graphic
displays.

Time Measurements
An estimate of the measurement signal to noise ratio and its levels are shown in this window
each time the button boxed in blue is clicked to generate a measurement in the main Data
Gathering Window pictured above.

Impulse Response
The impulse response is not very useful for looking at reflection behaviour. The impulse is only
useful for determining that the impulse response starts at t=0 ms and that the analyzer took a
correct measurement, otherwise it is useless and causes beginners to draw erroneous
conclusions. RPlusD has a full featured ETC curve set to look at reflections closely. To see this,
select impulse response (boxed in red) then click the options box (boxed in blue). The options
box below appears.

Time Display Options
The options selected that are boxed in blue and red make the single ETC curve the default time
curve.

Single Curve ETC display
The band filtered ETC curves appear when the arrow keys are selected (boxed in blue in the
Time Display Options figure above). A set of up to three band filtered ETC curves can be viewed
for each of the measurements in the buffers. The default time here is 30 ms and this cannot be
changed. This allows a more detailed view of the ETC curve to be viewed in the context of
speaker radiation of different drivers. In the above measurement a two way speaker is used and
the reflected energy from the HF driver is much greater than that from the LF driver.
From the top menu the selection Tools->Large Room gives the following window. Experimenting
with the frequency range selected gives varying degrees of detail in the display. Any time range
or level range can be selected from this window using the mouse.

Large Room Tools ETC display
This window provides other tools for looking at reverberation time and schroeder plots as well.
RPlusD uses the two measurement method for measureing RT/60. For a measurement of RT/60
in RPlusD two measurements are taken with the mic in each position. The software can store up
to 32 measurements and therefore measure RT/60 from up to 16 individual mic positions. The
two measurement technique gives much better signal to noise ratio for each RT/60 measurement
than the single mic method. The ability to average results from various mic positions in the room
gives greater accuracy as well. See the help content (blue question mark in window picture above
above) for specifics on how to measure RT/60.
A low frequency impulse may be viewed from this window as well.

Low Frequency Impulse

Frequency Response Measurements
RPlusD has a variety of frequency response measurement types that comprise the standard set
of response types included in the functionality of audio analyzers.

Bode (unprocessed) Frequency Response

Averaged Bode Response
The Bode response is an un-smoothed response and often shows too much detail and that detail
is usually due to reflections. Curve smoothing using a moving average gaussian window
produces the smoothed result in the fractional octave displays and filters out the affect of
reflections.

Fractional Octave Response - (1 oct - 1/20 oct resolution)

Psychological Response
The psychological response uses a varying gate time. The curve is composed from
measurements that have the gate time change dependent on frequency. Long gate times are
used at lower frequencies. The gate time is reduced as frequency is increased until the gate time
becomes 5 ms at approximately 200 Hz. At frequencies above 200 Hz the data is smoothed to
provide a 1/3 octave resolution. This gives a better indication of overall frequency response as
heard be a listener. The other measurements are better used to identify specific system
pathologies such as resonances.
When all three types of responses are calculated they can be viewed as individual curves when
the average button is not clicked (boxed in red) when the arrow keys are clicked (boxed in blue).

Single Curve Response
The average of all responses may also be shown. Notice that this shows 6 curves. This feature is
normally used when the internal EQ emulator is used, which it is not here. The filtered and
unfiltered curves are identical in this case because filtering is not used. The filtered curves
overlay the unfiltered and are shown with an asterisk on their display label. This display is seen
when the arrow keys in the Results frame are clicked with the average button enabled.

Averaged Response
The software also provides an indicator of signal to noise ratio of the measured set of curves as
an average or viewed individually from the arrow keys inside the Results frame as with all
frequency response measurements.

Estimated Measurement Signal To Noise (all curves)

Estimated Measurement Signal To Noise (Average)
The waterfall display averages all curves to produce a clean waterfall display with an absence of

dips. The user selects an area of the frequency response with the mouse that contains about 10
peaks to display as below.

Averaged Bode (unsmoothed) Response
Clicking the button boxed in red generates a nice looking waterfall display. The trick is to grab a
frequency region on the display with about 10 peaks, the software does the rest. This takes a few
minutes because the software caculates the waterfall display for each measurement then
displays an average. This provides a much better picture of room decay then a waterfall of only
one measurement.

Averaged / waterfall
Good looking waterfall plots are always automatically generated provided the user grabs about 10
peaks or less on the frequency response display with the mouse before clicking the waterfall
button. The software determines the noise and decides all limits automatically. Single waterfall
displays can be viewed by clicking the arrows. Clicking "filtered" or "unfiltered" returns the display
to its default averaged format. If an EQ is emulated then the waterfall plots before and after
EQing can be quickly compared using an average of all measurements.

Equalization
The add on package provides curve fitting to speed up filter approximations. Users that do not
purchase the add on feature still have access to a very powerful EQ emulator but filters must be
set manually.

Curve Fitting (Requires add on enhancement package)
Curve fitting is done by selecting a portion of the response while holding the right mouse button
down. Clicking on the two estimates of 52.15 Hz and 47.48 Hz from the above lower text box
generates a set of filters to be applied to the measurements. These are shown in the larger upper
text list shown in the figure below. These filters can also be manually generated from the 'Filters>New Filter' menu selection and their settings can be fine tuned manually.

Parametric Control for Behringer DSP 1124P Emulator
In this example the Behringer DSP 1124 is emulated and the control settings represent exact
discrete control settings in the Behringer unit. This is an emulation and the red curve shows
exactly what the Behringer EQ would do if that setting was selected. EQ emulation is one of the
flag ship features of the software. With RPlusD you only measure once. The affect of the
Behringer setting can be viewed from the averaged curves or from any individual curve. RPlusD
requires that you measure and EQ only once - no need to remeasure after determining an EQ
setting because RPlusD uses exact emulation of the hardware EQ internally.
This powerful feature lets you set an EQ to up to 32 measurements loaded in memory - much
better than setting an EQ in real time !!

EQ Emulation Selection
Three Behringer units are emulated. This window is available from Filters->EQ Emulation. If a
Behringer is not used an EQ can be set to Bristow Johnson or Classic. RPlusD provides a utility
to set your particular EQ to the RPlusD solution by connecting it to your sound card and setting it
while watching a display update in real time. The hardware EQ is set until its filters match the idea
dilter response found in RPlusD using all of your measurements. The software provides a
resampling utility to resample measurements to the sample rate used by a given equalizer. This is
necessary for exact emulation.

RTA for EQ setting
Using the above RTA EQ window from File->New->EQ RTA provides the capability of tuning the
above display in real time while your EQ is adjusted until the response is flat. The external EQ is
set to the ideal solution found in RPlusD when this is complete. This feature enables any EQ to
be set precisely according to 32 measurements rather than set in real time to only one
measurement.

SPL Measurement
RPlusD provides an SPL measurement that can be taken with the software. It does require an
initial calibration to a known SPL. This enables users to measure SPL differences between the
frequency range selected. It is ideal for measuring losses through doors, etc.

SPL Display

Distortion
The software provides two types of distortion measurements. Text files can be exported showing
the characteristics of the distortion. Distortion is a complex topic but beginner users can use the
multitone distortion measurement to get a single distortion figure for their system in typical room
conditions without doing the experiment in lab conditions. This is useful to compare different
speakers and to measure the point of overload. Figures around 10 % are normal but a sudden
increase in distortion with varying levels is indicative of overload conditions. Distortion itself is
hardly audible but an access of it does signal an overload.
Correct measurements using the two tone method are difficult to obtain in typical situations and
this feature is reserved for users with a sophisticated understanding of audio measurements.

Two Tone Distortion Measurement

Multi Tone Distortion Measurement
The multitone distortion measurement excites the system with 10 computer selected tones and
adds up the various distortion products. There are over 600 distortion products that are added to
form the single distortion figure.
The multitone measurement was carefully designed to allow for slight sample rate errors in sound
cards that are common. A 48 Khz sound card may actually sample at 47.99 KHz and this would
reduce accuracy in less sophisticated multitone implementations.
Data can be exported in text format when either Two Tone or Multi Tone distortion measurements
are used.
Connections to the system are identical to the standard connections used for room/speaker
measurements.
Distortion common in sound cards prevents this from having the accuracy required to measure
electronic component distortion. This feature is ideal for measureing only loudspeaker distortion
unless a very high quality sound card is used for the measurements.
This measurement is explained in greater detail from the help topic available from its own Help
button.

Electronic Crossover Emulation & Setting
RPlusD provides a tool to set up electronic crossovers such as the Behringer DCX 2496
electronic crossover. This utility allows the emulation of a crossover through many independent
mic positions and therefore gives a great capability in setting electronic crossovers for the best
possible solution. It is a tricky but quick process. Users should attempt this only after gaining
familiarity with how the software works in emulating EQ's for normal measurements.

All electronic crossovers will provide the same filter function but correction biquads have non
standard Q's associated with them for various EQ's. There is not an industry accepted standard
for Q. When the DCX 2496 emulation is selected its biquads are exactly emulated in the software.

DSP XOver Emulation
Of course the EQ's found to work using this function can be set to any hardware EQ using
methods described for the EQ RTA feature.

Test Signal CD
In some cases such as measurements of automotive sound systems, a connection between the
computer and sound system is not possible. RPlusD provides a wireless method of obtaining the
impulse response. It is not perfect and users should get some experience using it before trusting
it completely. The limitations in accuracy are normally inconsequential when measuring sound
system for automobiles because these measurements are examined using fractional octave
measurements that filter out the artifacts associated with this method. In all other cases we
recommend the conventional method from the Audio Data gathering Window requiring the
computer be connected to the system under test.
This feature is only included with the enhancement add on package.
The test CD must be burned from our wave file created for this purpose. This required wave file
can be generated from the main menu under Tools->Test CD Creation and can then be used to
create a test CD from a CD burner.

Test CD Data Gathering

Test Microphone/Preamp Requirements
A stand or boom mount is necessary to use with a test microphone. High quality mic boom stands
can commonly be purchased very cheaply from musical instrument stores - usually about $30.00
USD. The microphone must be held in a stable position for any test.
Many people have the RS SPL meter and this is fine for room acoustic based measurements.
The more expensive calibrated microphones are only beneficial for equalization applied to mid
and high frequencies. Almost all loudspeaker monitors can benefit from some equalization when
it is done correctly such as in RPlusD software using many measurements
AcoustiSoft sells two microphone preamp combinations that have individually calibrated
microphones. The lower priced mic/preamp requires that the user have a suitable sound card for
use with the software. The higher priced unit has a sound card built in and plugs directly into a
USB port. The higher priced unit is better for professionals because it has fewer cable
connections required and is faster to connect. Check the web site for updated pricing.

MP-B model (requires sound card)

MP - B - USB (has direct USB connection & built in sound card)

Calibrated Microphone (includes clip for standard mic booms)
The same microphone is included in both the USB and non USB package.
RPlusD has a utility to convert any microphone calibration file to the type of file required by
RPlusD in cases where another brand of calibrated microphone is to be used. This data must be
supplied in the frequency domain.
This tool is available from the Tools menu selection on the main menu.

