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Software Overview

RPIlusD is designed to provide all necessary function to both measure room acoustics in the
context of small and medium sized rooms in the context of playback. It provides full digital EQ
emulation and a user interface necessary to set parametric EQ's correctly as well as better ways
of looking at reflection and reverberation data than in ETF and is better than ETF in many small
ways that are beyond the scope of its documentation.

RPlusD can be used to test and compare subwoofer placements, measure loudspeaker
frequency response for the purpose of precise IIR filter equalization, measure the power
response of loudspeakers over a listening area, measure reverberation time, and measure ETC
reflection data using steep band bass (8th order) filters in up to three separate bands to compare
individual driver radiation reflections as well as perform many other functions. It contains
emulation for DSP equalizers Behringer model DCX 2496, FBQ 2496, DSP 1124P and should be
found to be an indispensible tool for users of these products as well as other DSP equalizers.

The basic version includes the very useful & powerful multitone and dual tone distortion
measurement through user selectable frequency ranges and order of product.

The enhancement package adds curve fitting, wireless test CD data gathering and DSP
crossover emulation. Curve fitting provides precise identification of resonances and the DSP
crossover emulation allows the settings for bi-amped or tri-amped DSP crossovers to be
determined using EQ emulation through multiple measurements.

Support Documentation

All of the support documentation can be downloaded from the web site
http://www.etfacoustic.com/RPlusDSite/index.html

Videos titled Ch1 - Ch4 illustrate the program operation and the the user interface. Use of the
software is illustrated and discussed and these videos explain the use of the software user
interface while explaining what the measurements mean. The first video explains the sound card
connections and mixer settings required for the sound card to take measurements. These should
be downloaded an unzipped in WinZip which can be downloaded and installed for free. The
preferable viewer is QuickTime but Explorer and others will play these SWF files.

The support document Intro.PDF does the same function as the videos and explains some
additional features not shown in the videos such as measurement of RT/60. These are designed
to illustrate how the software is used.

The document AplicationNotes.PDF explain how to read measurements and conduct proper
experimental procedure. The document FrequencyResponse.PDF explains many particular
aspects of frequency response measurements and explains additional experimental procedures
with many examples in the context of EQing. In all cases we advocate the use of multiple
measurements to get meaningful and repeatable measurements. Users should understand the
document FrequencyResponse.PDF to understand the software and its measurements even if
they do not intend to use EQing.




The document_XOvers.PDF outlines the digital crossover simulator in RPIusD. This is of interest
from users of the Behringer DCX 2496 or other similar units to bi-amplify or tri-amplify
loudspeakers using DSP based electronic crossovers.

Equipment Required

In addition to a microphone, users should obtain a musicians microphone stand to act as a boom
to allow flexible microphone placement. These can be found in music stores for about $35.00
USD. Electrical tape can be used to secure the RS SPL device to this boom. Cables required are
illustrated in the Intro.PDF document as well as the Ch1 video.

Computer

RPIlusD will run in any Microsoft operating system from Windows 95 forward to present. Users
will want to have 256 Mb of memory and a fast processor (1+ GHz ) to take full advantage of all
the software at a convenient speed. Slower computers can be used with no problems.

Sound Card

Virtually any sound card with the capability of recording and playing back simultaneously (full
duplex) will work with the software. The user is only required to set up the sound card and mixer
once during the first time the software is used. The automatic mixer (enabled from Options->
Mixer on menu) will remember the settings and selection of sound card and will automatically
select the sound card and set its mixer when ever the software is used to take measurements
again. The Sound Blaster MP3 is good because it has RCA type phono connectors instead of the
typical 1/8 " stereo plug but almost any USB card will work.

Laptop computers should use USB soundcards. It is a safe assumption that almost any low cost
USB sound card will work with the software. In the case of desktop computers just about any
sound card you can find in your grocery store discount bin will work provided it is full duplex and
most are. Some recording studio soundcards do not have * WDM Windows audio drivers. In
almost all cases these can be downloaded as third party drivers at no cost.

This is a simple set up procedure that is explained in RPlusDIntro.PDF as well as illustrated by
video in the first video of a series currently titled Ch1 - Ch4.

Microphone

Any microphone that is omnidirectional will work for acoustic based measurements. The Radio
Shack digital or analogue SPL meter is normally all that is required provided measurement
accuracy below 5 KHz is all that is required. This is the case for room measurements.

In a case where equalization is to be used an individually calibrated microphone is required. This
is necessary to measure frequency response accurately. We recomment our mic preamplifier
combination for this purpose. It is $325.00 for the individually calibrated mic and matching
preamplifier.

Sound Card Connections & Mixer Settings

Mixer settings for the input and output windows mixer are shown below. The mixer window can
be changed from input mixer to show the output mixer from its menu. This mixer is accessed from
the speaker icon in the lower right corner of the computer monitor. Correct settings are illustrated
for a typical sound card.
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The Play mixer should have the only source as Wave with all else muted.
This prevents the recorded signal from being replayed through the speakers
and causing feedback. Note the muted line input.
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The Record mixer should be set to record only from the line input
connector. Never use the microphone as an input and mute or shut
down other inputs except line input if necessary.



Sound Card Connections

Line In Line Out
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The sound card connections for the loop thru test required to ensure that the sound
card is working correctly.

Sound Card Connections

To Microphone To Audio System Line
| Input
Line In Line Out
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The sound card electrical connections should be changed to the connections shown
here for an actual room measurement



] AcoustiSoft R+D / C:, iml x
File 0Options ‘iew Filkers Tools Help i} Audin Data Gathering x|

o == ?

By dic Right I_dB Rf Left
- [ sM [ sM
‘!.' iz - I_ mn micAzpkr path
i ° Excitation Time
f oo —fr— [3 s [ PSD
S Iﬁ Pre E xcitation [z]

08 = —Mics/Spkr Digtance

-2a - &+ Auta [full range testing]

=k el g g , s " Manual 0.0 [[I:l-?itr:rf:espeaker
gg Etj;:'ﬂms %&_TEMIW e ™ MLS [Xover Sim)
;E_ =] _llw f* Hybrid
Lllz 1”1_ " Sweeps " IEDEI -

The loop thru test shows the appearance of a successful test with the sound card wired in the
loop through test configuration

USB Microphone / Preamp

The MP B USB mic/preamp available as well for $425.00. Its additional cost provides a built in
USB sound card. There are only two connections to be made - one from the mic/preamp to the
audio system and one from the microphone to the mic/preamp. This saves the trouble of
additional external connections and the need for a sound card.

The mixer settings for RPlusD to work with this unit are shown below. It is not necessary nor is it
possible to perform the loop through test as in the video Ch1 and in Intro.PDF. The required
settings are for this sound card are known and the loop back electrical connection shown in the
videos for the left channel is a connection made internally. It uses the Windows driver that will
automatically load when this is plugged into a USB port.

The first step in setting up this unit is to select the sound card from the options button from where
measurements are usually taken File-> New->Sound Card Measurement. The sound card can be
selected from the yellow Options button on the window that appears on that window leading to
the window displayed below. This setting has the right channel as the microphone input and the
left channel in loop back. Switching to mic Left would have the loop thru channel as the right
channel.
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Select the sound card

The mixer can be opened by clicking the speaker icon in the lower right hand task bar in
Windows. Click on the speaker icon will cause the window below to appear. From its options
window select the new USB sound card.
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Set mixer values

The play out settings should be set as shown. The levels can be reduced. The above settings
provide approximately -1 dB of input level on the left reference channel. The software will work
fine of this is at -10 or even - 20 dB. The signal to noise ratio is about 50 dB with these settings. A
signal to noise ratio greater than 20 dB is normally acceptable.

This sound card does not have line in level controls in the default windows driver. This does not
matter because the software works perfectly with this default driver installed.

Once these controls are set, select Options->Mixer->Mixer On from the main menue. When the



software is closed you will be prompted to save these settings.



Taking Room Tests

After the loop through test is completed sucessfully a room test can be taken with the change in
connections as illustrated in the above connection diagrams. The Start Test button will be used to
take these measurements as shown below:
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Circled "Start Test" button

The Start Test button is then used to conduct a test with the sound card connected to the
microphone and computer.

Full Range speaker measurements are normally conducted with the Mic/Spkr Distance set to
Auto. One way to verify the correctness of your measurements is to verify that the software

measured the mic - speaker distance correctly as shown in the right lower corner of the form
below.
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Single Impulse Measurement in Set of 4 Measurements

The mic - speaker distance should be very close to the actual mic - speaker distance.
Propogation delays through DSP processors may make this figure larger than the actual physical
distance.

The impulse peak should be seen to start at very close to t = 0 ms on the bottom axis.

The signal to noise ratio should normally be above 15 dB. The estimate of signal to noise ratio is
a very crude estimate shown here.

The input signal level should be above approximately - 15 dB and below 0 dB. The actual level is
not critical.

In the above measurement the autorange feature was used to automatically measure
mic/speaker distance. In some cases the software may not be able to align the impulse correctly.
In this case select "manual” and type in the distance between the mic & speaker manually.

If only a subwoofer is measured the "manual” selection for mic - spkr distance should be selected
and the results should look something like the example below.
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Set of 32 Subwoofer Measurements

Clicking the button circled in red in the above window makes the options box shown below. Click
the option for "Apply Impulse Filter" in the window below.
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Options Box For Time Display

The full low frequency impulse can be seen when the single curve arrows are selected providing
a full time span view of the low frequency impulse response.
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Single Low Frequency Impulse

The arrows circled in the window above show the single curve impulse response over a long
period of about 650 ms when clicked. In this way each measurement can be viewed clearly.




